Email Server failing to send emails to microsoft based emails.
Incident Report for Miffed Hosting
Resolved
This incident has been resolved.
Posted Apr 28, 2022 - 21:36 UTC
Investigating
Email Server failing to send emails to microsoft based emails due to block of network range. We are currently in contact with Microsoft to have the issue resolved.
Posted Apr 06, 2022 - 11:38 UTC
This incident affected: Hosting (Shared).